🐞(KNOWN BUG): Aufgaben werden nicht erstellt, wenn E-Mails an die Projektspalte gesendet werden

Miša
Miša Admin, MeisterLobster Posts: 339 Community Admin
edited January 25 in News & Updates

*** EDIT 25.1.2023: Es sind aktuell 2 Probleme bekannt:

1) Mails mit Hashtag werden nicht verarbeitet

2) Automationen in per Mail eingefügten Tasks werden nicht ausgeführt

Die Behebung der Probleme hat bei unseren Entwicklern zur Zeit oberste Priorität.

***

Hey!

Unsere Entwickler haben gerade ein Problem mit der E-Mail-Verarbeitung in MeisterTask entdeckt:

Es werden derzeit keine Aufgaben erstellt, wenn E-Mails an einen Projektabschnitt gesendet werden.

Wir sind uns des Problems bereits bewusst und unsere Entwickler arbeiten daran, es so schnell wie möglich zu beheben.

💡 Achtung - Sobald der Fehler behoben ist, müssen Nutzer bereits gesendete E-Mails erneut senden, damit die entsprechenden Aufgaben automatisch erstellt werden!

Wir halten euch hier auf dem Laufenden und entschuldigen uns für die entstandenen Unannehmlichkeiten.

Tagged:

Comments

  • Edmar_DA
    Edmar_DA Member Posts: 4 Beginner

    Hallo,

    seid Ihr sicher, dass das Problem (Thread-Titel) gelöst ist? Seit ich MT nutze, habe ich immer mal wieder versucht, Mails an die Mail-Adresse zu schicken, die genannt ist unter dem Menü-Punkt:

    "Sie können Aufgaben per E-Mail in diese Spalte einfügen:"

    Das klappte in den allermeisten Fällen nicht --- nur hin und wieder kam mal eine Mail durch und erstellte eine neue Aufgabe. Deswegen habe es irgendwann aufgegeben ... bis ich hier diesen "solved" Post entdeckt habe. Von zwei Test-Mails gerade kam jedoch nur die Zweite als Aufgabe in meinem MT-Panel an. Mit so zufälligen Resultaten macht das leider keinen Sinn.

    ( oder geht's hier gar nicht um dieses Thema? )

    Danke und viele Grüße

    Edmar

  • Nils Wortmann
    Nils Wortmann Member Posts: 3 Beginner

    Guten Tag,

    ich habe das Problem, dass seit ca Mitte Januar meine Mails nicht mehr als Aufgaben erstellt werden.

    Nach ein paar unterschiedlichen Versuchen habe ich festgestellt, dass einige Mails als Aufgabe erfasst werden und einige nicht. Leider kann ich nicht ausfindig machen, was die Ursache ist.

  • Nils Wortmann
    Nils Wortmann Member Posts: 3 Beginner

    Guten Tag,

    ich habe nun das Problem gefunden.

    Immer wenn eine Mail "#" enthält, wird daraus keine Aufgabe erstellt!

  • Jörg Koper
    Jörg Koper Consultant & Coach Hannover & HamburgMember, DACH Partner Posts: 325 Mastermind

    Moin @Nils Wortmann 👋🙂

    Ich habe versucht, das zu reproduzieren. Bei mir klappt es einwandfrei. Auch wenn # im Betreff und Textfenster der Mail enthalten ist. Hast du es zwischenzeitlich nochmal probiert?

    Schöne Grüße, Jörg

    Als Experten-Partner von Meister führe ich in meiner Agentur u. a. Workshops für die Integration der Meister Software durch. Hier in der Community freue ich mich auf den Austausch mit Euch und helfe bei Fragen zu MeisterTask, MindMeister und MeisterNote gerne weiter.


    Weitere Informationen findest du auf agenturkoper.de

  • Nils Wortmann
    Nils Wortmann Member Posts: 3 Beginner

    Hallo @Jörg Koper

    Ich habe es gerade nochmal von unterschiedlichen Mailaccounts probiert, es wird keine Aufgabe erstellt. Dann wird das Problem an meinem Board liegen...

    Seltsam ist nur, dass es bis vor wenigen Tagen noch funktioniert hat.

    Viele Grüße

    Nils

  • Jörg Koper
    Jörg Koper Consultant & Coach Hannover & HamburgMember, DACH Partner Posts: 325 Mastermind

    @Nils Wortmann

    Hi Nils,

    als generellen Tipp kann ich Dir zumindest empfehlen, Dich einmal komplett auszuloggen, den Browser-Cache zu löschen und dann neu zu starten...evtl. auch mal mit einem anderen Browser (Google Chrome ist bisher am stabilsten) testen. Anschließend wieder einloggen und die Funktion erneut ausprobieren. Ich drücke die Daumen 🤞

    Schöne Grüße, Jörg

    Als Experten-Partner von Meister führe ich in meiner Agentur u. a. Workshops für die Integration der Meister Software durch. Hier in der Community freue ich mich auf den Austausch mit Euch und helfe bei Fragen zu MeisterTask, MindMeister und MeisterNote gerne weiter.


    Weitere Informationen findest du auf agenturkoper.de

  • scubatinoo
    scubatinoo Member Posts: 5 Beginner

    Das Problem ist keinesfalls gelöst. Wir bekommen seit Mitte Januar keine Tasks aus Mails mehr, in denen Tags mitgeliefert werden. Gemäss Anleitung soll das mit #wichtig erfolgen, wenn der Tag in Meistertask auch "wichtig" heisst. Lässt man den Hashtag weg, kommen die Tasks aus Mails wieder an... Allerdings funktionieren auch die Automationen auf per Mail eingefügten Task nicht, so bleibt z.b. die automatische Zuweisung an einen Projekteilnehmer aus.

    Ich habe den Support bereits darauf hingewiesen, sie arbeiten daran. Angeblich soll es etwa zwei Wochen dauern...

  • Stefan David
    Stefan David Member Posts: 4 Beginner

    Ich habe hier das gleiche, sehr ärgerliche Problem seit einigen Tagen. Tasks werden zwar erstellt, Automationen, die darauf laufen sollen, werden aber nicht erledigt. Ich hoffe, der Support bekommt das schnell wieder in den Griff.

  • scubatinoo
    scubatinoo Member Posts: 5 Beginner

    Der Support hat mir geschrieben, dass sie die Probleme erkannt und an die Entwickler weitergeleitet haben... Ich nehme an, dass der Support ein Ticket in Indien erstellt hat und jetzt warten muss, bis dieses abgearbeitet wird... Ärgerlich ist vorallem, dass die beiden Funktionen bislang einwandfrei funktioniert haben. Wenn die neue Softwareversion schlechter ist als die Alte, dann hat bei der Qualitätskontrolle jemand versagt...

  • Stefan David
    Stefan David Member Posts: 4 Beginner

    @scubatinoo Ich hoffe mal, dass es tatsächlich schnell geht, wenn das Problem schon erkannt wurde. Bugs schleichen sich ja gern mal ein. In diesem Fall sollte es hoffentlich leicht zu lösen sein. Da es bisher so einwandfrei funktionierte, habe ich das auch an ziemlich kritischer Stelle eingesetzt, was jetzt viel händischen Aufwand erfordert.

  • scubatinoo
    scubatinoo Member Posts: 5 Beginner

    @Stefan David wir generieren zum Teil mehrere dutzend Tasks mit einer externen App, welche dann an Meistertaks gesendet werden. Zum Glück sind die "Originale" gespeichert, so dass wir sie nochmals ohne Hashtag schicken konnten... Sonst wären wir auch aufgeschmissen gewesen.

    Aber immerhin: Der Mailserver scheint schneller geworden zu sein! Wenn die Tasks erscheinen, dann eigentlich unmittelbar nach dem Senden. Das hat vorher immer ein paar Minuten gedauert... Also nicht alles schlecht was neu ist :-)

  • Andrew Lapidus
    Andrew Lapidus Admin, MeisterLobster Posts: 408 Community Admin

    Hallo zusammen @Stefan David @scubatinoo , auch ich wollte mich hier kurz zu Wort melden. Unsere Entwickler sind jetzt darüber informiert worden, dass Hashtags derzeit verhindern, dass die Funktion "E-Mail an Aufgaben" funktioniert. Da viele Nutzer auf diese Funktion angewiesen sind, hat die Behebung dieses Problems für uns eine hohe Priorität.

    Wir entschuldigen uns für die Unannehmlichkeiten und die jüngsten Probleme mit dieser Funktion - unser Team hat vor kurzem die Infrastruktur hinter dieser Automation aufgerüstet, was die Geschwindigkeit deutlich erhöht, aber auch einige unerwartete Probleme verursacht hat. Ich werde diesen Thread mit weiteren Details auf dem Laufenden halten, sobald sie bei mir eintreffen!


    Beste Grüße,

    Andrew

  • Stefan David
    Stefan David Member Posts: 4 Beginner

    @Andrew Lapidus Danke für die Rückmeldung. Aber um das klarzustellen: Mein Problem ist nicht der Hashtag (weil ich keinen benutze).

    Die Aufgaben werden wie gewünscht erstellt. Allerdings greift dann die Automation in der Spalte nicht. Die Aufgaben bleiben einfach unverändert.

    Mein Kommentar bezog sich auf die Aussage von @scubatinoo "Allerdings funktionieren auch die Automationen auf per Mail eingefügten Task nicht, so bleibt z.b. die automatische Zuweisung an einen Projekteilnehmer aus." Genau das ist bei mir der Fall.

    Die korrekt erstellten Aufgaben werden also nicht wie gewünscht zugewiesen, es wird kein Fälligkeitsdatum gesetzt und auch das Verschieben in ein anderes Projekt wird nicht durchgeführt.

    Wenn ich in der Spalte die jeweilige Automation bearbeite und dabei die Option setze "Diese Automation auf alle bestehenden Aufgaben in dieser Spalte anwenden", klappt es. Nur bei Tasks, die über E-Mail in der Spalte angelegt wurden, klappt es nicht.

    Beispieldaten liefere ich gern. Ich gehe davon aus, dass du als Admin meine E-Mail-Adresse sehen kannst, um mich direkt zu kontaktieren.

    Beste Grüße

    Stefan

  • scubatinoo
    scubatinoo Member Posts: 5 Beginner
    edited January 24

    @Stefan David Es sind aktuell 2 Probleme bekannt:

    1) Mails mit Hashtag (für die Markierung mit Tags, z.B. #wichtig) werden nicht verarbeit, kommen also nicht als Task im Projekt an

    2) Automationen in per Mail eingefügten Tasks werden nicht ausgeführt


    @Andrew Lapidus korrekt? Und besten Dank für die Nachricht mit den Erläuterungen.

  • Andrew Lapidus
    Andrew Lapidus Admin, MeisterLobster Posts: 408 Community Admin

    ☝️Genau - beide Probleme sind bekannt und die Behebung der Probleme hat bei unseren Entwicklern zur Zeit die "Priority 1". Tut mir leid, dass ich mich nicht klar ausgedrückt habe, und vielen Dank für die Zusammenfassung, @scubatinoo!

    Wir konnten beide Bugs intern duplizieren und erleben genau das, was Du beschrieben hast, @Stefan David . Ich melde mich per E-Mail, falls wir weitere Informationen benötigen. 👍

    Ich werde diesen Thread über Entwicklungen auf dem Laufenden halten, und mich hier melden sobald ich mehr Informationen habe.

    Beste Grüße und schönen Mittwoch,

    Andrew

  • Andrew Lapidus
    Andrew Lapidus Admin, MeisterLobster Posts: 408 Community Admin

    Hallo zusammen! Eine Lösung für das zweite der oben genannten Probleme wurde gerade implementiert - Automationen in per Mail eingefügten Tasks sollen jetzt funktionieren.

    Wir arbeiten weiter daran, das Problem mit Hashtags in E-Mails zu lösen, weitere Updates werden folgen.

    Beste Grüße,

    Andrew

  • scubatinoo
    scubatinoo Member Posts: 5 Beginner

    Hallo @Andrew Lapidus Danke für die Information. Ja, Automation funktioniert wieder.

    Hashtags führen immer wieder zu Fehlern, weil sie je nach Skript-Sprache mit Funktionen belegt sind. Wenn der Hashtag also Probleme bereitet, dann nehmt doch einfach eine anderes Zeichen oder eine Kombination von Zeichen, die einen Tag einleiten und problemlos geparst werden können, %%T:wichtig oder <tags>wichtig oder whatever... :-)

    Jedenfalls Danke für eure Bemühungen!

  • Stefan David
    Stefan David Member Posts: 4 Beginner

    Ich kann ebenfalls bestätigen, dass es wieder läuft. Vielen Dank, @Andrew Lapidus für die schnelle Reaktion und Rückmeldung.